BaiCE BM 2.5.26 - New CPE software has been released!

New firmware for Atom R9 Cat4 Gen2 CPEs has been released. Starting with this release, the naming convention for Cat4 CPEs is changing from “BaiCE AP” to “BaiCE BM”. This is mainly due to adding support for new hardware (Qualcomm Cat4 modem).
Highlight features for this release are:

  • WiFi alignment
  • Tunnel mode (for upcoming HaloB L2)
  • STUN (for quicker SAS registration)
  • L2TPv3 Support

:warning: NOTICE: Starting with version BaiCE BM 2.5, SAS will automatically be enabled when the CPE connects to a Band 48 cell. Registration with the SAS is required before regular data traffic is allowed on the WAN interface. Only exception to this is when using the EUD firmware which restricts max EIRP to 23dBm.


  • Atom OD04H (EG7035E)
  • Atom OD04L (EG7035L)
  • Atom ID04 (EG2030C)

Software Download: BaiCE_BM_2.5.26

Module Firmware:


Version BaiCE_BM_2.5.26

New Features:
- Added: WiFi alignment
- Added: Tunnel mode on WAN Settings page 
- Added: Support uploading logs to OMC
- Added: L2TPv3 Support
- Added: 4 APNs can be configured on APN Management page
- Added: Option 43 LAN DHCP configuration
- Added: Wifidog captive portal
- Added: Display TX Power in webgui 
- Added: Display LAN link speed in webgui
- Added: TR069: Support STUN client
- Added: TR069: Support password changes via OMC 
- Added: TR069: Support WiFi and LAN configuration
- Added: TR069: Support WAN configuration
- Added: TR143: Support Traceroute
- Added: TR143: Support Ping 
- Added: TR143: Support Download/Upload 
- Added: TR143: Support UDPEchoPlus
- Added: SAS: Automatically enable SAS when B48 is selected 
- Added: SAS: Add unit of measurement dropdown for height install parameter 
- Added: Log: Added "System Messages" page 

Bug Fixes:
- Fixed: HTTPS switch can not be configured via OMC
- Fixed: WiFi not to turned OFF after WiFi is turned ON via OMC and WLAN Expire Time triggers
- Fixed: WiFi password cannot be changed 
- Fixed: DNS cannot be configured on WAN Settings page 
- Fixed: "rfc1918 error" is displayed when logging in to webgui from WAN IP
- Fixed: MTU will reset to 1358 after reboot if MTU is changed
- Fixed: APN IP address is not displayed when in Bridge mode
- Fixed: LTE module upgrade via OMC may fail
- Fixed: GRE L2 interface is not created successfully after reboot
- Fixed: Multi APNs IP addresses are abnormally displayed
- Fixed: DHCP lease time can be set out-of-range
- Fixed: WAN MAC address is changed when restoring config file from another CPE
- Fixed: LAN devices cannot access the internet in Bridge mode when VLAN is set to non-zero value
- Fixed: Ping Watchdog was not triggering as expected
- Fixed: No redirection to login page after factory reset
- Fixed: No error checking on DHCP Lease time on LAN Settings page
- Fixed: CPE with module MT421E will offline from OMC after running several days
- Fixed: ODU with EP3011 (SnapRouter) will reboot frequently after factory reset
- Fixed: TR069: Applying frequency locks via OMC fails
- Fixed: SAS: Failure to backup SAS certificates when upgrading with keeping-config
- Fixed: SAS: CBSD can still pass traffic in Bridge mode without SAS authorization
- Fixed: SAS: CBSD does not re-register with SAS when changing frequencies in Direct SAS mode

- Improved: WiFi Cipher is changed to AES 
- Improved: Removed “Antenna Model” and “Group type” on SAS page 
- Improved: Changed "Periodic" to "Keep-Alive Interval" on TR069 page 
- Improved: Redesigned WAN settings page 
- Improved: Firewall rules are automatically configured when "Allow SSH access from the WAN port" is set 
- Improved: Rename “Bundled Address List ” to "DHCP Reservations"   
- Improved: SSH can be enabled/disabled on Diagnosis page 
- Improved: Change the pop-up window text to "Username or password is incorrect"  when login credentials are incorrect
- Improved: Under WEB setting page, rename "HTTPSPort"/"HTTPPort" to "HTTPS Port"/"HTTP Port"
- Improved: TR069: Optimize TR069 service CPU usage
- Improved: Security: ACS server is set to HTTPS by default


I tried this new version on some of my CPEs.
It works well for those with MLHxxxx module, but those with MT421e module don’t reconnect to my acs (genieacs). I ran a tcpdump capture on my epc, they don’t try to contact the acs at all. They also don’t try to resolve the acs dns name.
They all seem to be configured the same way.
Any idea ?



Hello Mathieu!

Please open a ticket with our support team.